Light Style© by Fisana

Jump to content


Photo

Ugly gray rectangles around 3D-Objects


  • Please log in to reply
11 replies to this topic

#1 LinMintzer

LinMintzer

    Tiro

  • Community Newbie
  • 2 posts

Posted 18 February 2012 - 06:23 PM

Hi,
I'm using a notebook with an Intel HD 3000 graphic card, Intel Core I5 2430M processor and Linux Mint 12 (64 Bit) on it. I just installed 0AD and checked out the functionality. Unfortunately I had to detect a graphical fault: Around some 3D-Objects and almost every building I built is an ugly gray rectangle:
Posted Image

Does anybody know how to fix this problem? Is the Intel graphic card the reason?

Edit: Here is a bigger version of the picture: Screenshot

Edited by LinMintzer, 18 February 2012 - 06:26 PM.

  • 0

#2 feneur

feneur

    Cartographer of imaginary worlds

  • 0 A.D. Project Leader
  • 7,960 posts

Posted 18 February 2012 - 06:36 PM

It seems like it's due to your graphics card/the drivers for your graphics card. Where the gray rectangles are should be decals (2D images overlaid over the terrain to help make it look like the buildings are really in the world). I'd suggest first trying to see if there is a newer/better version of the drivers for your graphics card, that's hopefully going to fix it (unless the graphics card doesn't support the underlying features we use to display the decals in which case I'm not sure there is much to do, hopefully that's not the case though as it obviously can run the game in general :) ).
  • 0

Erik Johansson [ aka feneur ]

Wildfire Games
Contact me: feneur@wildfiregames.com



Support Wildfire Games!


#3 Ykkrosh

Ykkrosh

    Primus Pilus

  • WFG Programming Team
  • 4,921 posts

Posted 19 February 2012 - 03:38 PM

Yeah, the problem is the decals' clamp-to-border textures (the border should be transparent, not that greyish colour), which I assume is a driver bug. What driver version are you currently using? ("glxinfo|grep OpenGL" should say.)
  • 0
Philip Taylor [aka Ykkrosh]

Wildfire Games Programmer
Contact me: philip@wildfiregames.com

#4 LinMintzer

LinMintzer

    Tiro

  • Community Newbie
  • 2 posts

Posted 19 February 2012 - 05:48 PM

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel® Sandybridge Mobile
OpenGL version string: 2.1 Mesa 7.11
OpenGL shading language version string: 1.20
OpenGL extensions:
  • 0

#5 DirectGL

DirectGL

    Tiro

  • Community Members
  • 4 posts

Posted 10 March 2012 - 01:19 PM

Exact same problem with an Intel HD 3000 graphic card, on a mobile core i3 processor.
Tested with a 64bit Ubuntu 11.04 with the same driver.
No modified option in "$HOME/.config/0ad/config/local.cfg" was able to resolve it.

~$ glxinfo |grep OpenGL
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel® Sandybridge Mobile
OpenGL version string: 2.1 Mesa 7.11
OpenGL shading language version string: 1.20
OpenGL extensions:

:(
Is it possible to fix it without changing any driver ?
  • 0

#6 FeXoR

FeXoR

    Centurio

  • Community Members
  • PipPipPipPipPip
  • 950 posts

Posted 10 March 2012 - 01:34 PM

They only occur for me at the beginning of placement.
I got a ATI Radeon Xpress 1200.
It seams to me it is because the objects are loaded more slowly.
But since it occurred in the same revision (11291) the game did run much more smoothly, I think it's because the objects are loaded more dynamically.
Before this revision I simply used the alpha8 and it didn't happen there..
I installed a new driver, too, but it still doesn't happen in alpha8 for me.
For me the gray shape disappears after a few seconds.

Edited by FeXoR, 10 March 2012 - 01:47 PM.

  • 0

#7 feneur

feneur

    Cartographer of imaginary worlds

  • 0 A.D. Project Leader
  • 7,960 posts

Posted 10 March 2012 - 02:53 PM

They only occur for me at the beginning of placement.
I got a ATI Radeon Xpress 1200.
It seams to me it is because the objects are loaded more slowly.
But since it occurred in the same revision (11291) the game did run much more smoothly, I think it's because the objects are loaded more dynamically.
Before this revision I simply used the alpha8 and it didn't happen there..
I installed a new driver, too, but it still doesn't happen in alpha8 for me.
For me the gray shape disappears after a few seconds.

That's something else :) That's just that in the Alphas we use pre-converted textures (many textures are created as PNGs, but for performance reasons etc the game uses the DDS format), but when using SVN the textures are converted when you first see them on screen. While they are being converted they show up as grey squares. The next time you see them they're already converted and thus loads faster :)
  • 0

Erik Johansson [ aka feneur ]

Wildfire Games
Contact me: feneur@wildfiregames.com



Support Wildfire Games!


#8 DirectGL

DirectGL

    Tiro

  • Community Members
  • 4 posts

Posted 10 March 2012 - 03:18 PM

Ok, I can confirm it's something else for FeXoR with his ATI, I've just tested the Alpha 9 (11290) and it's not solving the issue.
  • 0

#9 nocompile

nocompile

    a.k.a trajans_advisor

  • Community Members
  • Pip
  • 73 posts

Posted 18 March 2012 - 10:02 PM

I have the same problem. Drivers are newest avalible on my distro. Could you add an option to work around this? "allow buildings to float y/n"
  • 0

#10 DirectGL

DirectGL

    Tiro

  • Community Members
  • 4 posts

Posted 21 April 2012 - 11:46 PM

Today I don't have this problem anymore (11582-development version) !
Nevertheless I don't see any difference between a game with the shadow mode option enabled and a map without it.
It is not a problem for me if it's the reason why the bug is fixed :)
Thanks a lot !
  • 0

#11 historic_bruno

historic_bruno

    Primus Pilus

  • WFG Programming Team
  • 2,482 posts

Posted 22 April 2012 - 02:26 AM

Today I don't have this problem anymore (11582-development version) !
Nevertheless I don't see any difference between a game with the shadow mode option enabled and a map without it.
It is not a problem for me if it's the reason why the bug is fixed :)
Thanks a lot !


Have you changed any settings in your config file? You might have disabled shadows by accident.
  • 0
Ben Brian [ aka historic_bruno ]

Wildfire Games Programmer
Contact me: ben [at] wildfiregames [dot] com

#12 DirectGL

DirectGL

    Tiro

  • Community Members
  • 4 posts

Posted 14 May 2012 - 05:04 PM

No I didn't changed any kind of setting.
When I enabled shadows, the game did look the same.
It might be a new thing since I changed my "headers" .deb packet in my linux distribution. So it can be an Intel's driver problem, or be related to my brand new kernel...

Now I use Linux 3.2.0 and glxinfo|grep OpenGL give me :
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel® Sandybridge Mobile
OpenGL version string: 3.0 Mesa 8.0.2
OpenGL shading language version string: 1.30

Sorry for not having more information.

Edited by DirectGL, 14 May 2012 - 05:08 PM.

  • 0