Light Style© by Fisana

Jump to content


Photo

Game Lag (when late in game)


  • Please log in to reply
7 replies to this topic

#1 BramKaandorp

BramKaandorp

    Tiro

  • Community Newbie
  • 4 posts

Posted 28 March 2012 - 05:14 PM

Not sure how to post this, I just decided to go for it.

This is basically the standard problem where the game either becomes slow, choppy or fluent but with major freezes in between movement parts.

I included the profile.txt as an attachment.

I hope it helps.

Details of my PC:

-Computer-
Processor : 4x Intel® Core™2 Quad CPU Q8200 @ 2.33GHz
Memory : 3348MB (719MB used)
Operating System : Ubuntu 10.04.4 LTS

-Display-
Resolution : 1920x1080 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA Intel

-Video Card-
VGA compatible controller : nVidia Corporation G96 [GeForce 9500 GT] (rev a1)



So far for the info. I really love the game so far, and I have high hopes for the future. Keep up the good work.

Attached Files


Edited by BramKaandorp, 28 March 2012 - 05:15 PM.

  • 0

#2 FeXoR

FeXoR

    Centurio

  • Community Members
  • PipPipPipPipPip
  • 938 posts

Posted 28 March 2012 - 06:29 PM

Welcome to the 0ad forum.

Your report seams to be the known issue posted in this topic as it says:

'Lag
The game does not run as fast as we would like. Late in the game you will probably experience some lag, this is caused by a mixture of things, AI and pathfinding are big ones. One thing that can be helpful is giving us the profiler information, if you hit Shift-F11 this will be dumped into a file (location given at the top of the screen), the contents of which are useful for working out where the lag is coming from so please upload.'

Maybe more hardware related information will be posted by other's more into it. As fare as I know multi core threading is not widely available throughout the games functionality.


  • 0

#3 BramKaandorp

BramKaandorp

    Tiro

  • Community Newbie
  • 4 posts

Posted 28 March 2012 - 06:37 PM

Welcome to the 0ad forum.

Your report seams to be the known issue posted in this topic as it says:

'Lag
The game does not run as fast as we would like. Late in the game you will probably experience some lag, this is caused by a mixture of things, AI and pathfinding are big ones. One thing that can be helpful is giving us the profiler information, if you hit Shift-F11 this will be dumped into a file (location given at the top of the screen), the contents of which are useful for working out where the lag is coming from so please upload.'

Maybe more hardware related information will be posted by other's more into it. As fare as I know multi core threading is not widely available throughout the games functionality.



Thanks for the fast reply.

I knew about the FAQ, but I didn't know where to upload my profile.txt file.
  • 0

#4 quantumstate

quantumstate

    Primus Pilus

  • WFG Retired
  • 1,150 posts

Posted 30 March 2012 - 09:36 AM

Thanks for the fast reply.

I knew about the FAQ, but I didn't know where to upload my profile.txt file.


It would be a good idea to provide somewhere where people could upload their files. The FAQ is pretty new so we haven't got the details sorted out properly.

Thanks for uploading yours. I took a look at it and it says that it is taking 34.251 msec/frame which should give you a solid 30fps. Is this profile report from a time when the game was lagging?
  • 0

Jonathan Waller [ aka quantumstate ]

Wildfire Games Programmer
Contact me: jonathanmarkwaller at gmail dot com


Support Wildfire Games!


#5 BramKaandorp

BramKaandorp

    Tiro

  • Community Newbie
  • 4 posts

Posted 30 March 2012 - 10:36 AM

It would be a good idea to provide somewhere where people could upload their files. The FAQ is pretty new so we haven't got the details sorted out properly.

Thanks for uploading yours. I took a look at it and it says that it is taking 34.251 msec/frame which should give you a solid 30fps. Is this profile report from a time when the game was lagging?


The problem is, I can't make a snapshot (is that the right word?) when it lags, or at least that's what it looks like. I'll try it again shortly.

ETA: Included.

Attached Files


Edited by BramKaandorp, 30 March 2012 - 10:39 AM.

  • 0

#6 quantumstate

quantumstate

    Primus Pilus

  • WFG Retired
  • 1,150 posts

Posted 30 March 2012 - 06:59 PM

Thanks, this one is more interesting. Could you give a few more details, I would like to know the game version, what map and how many AI's.
  • 0

Jonathan Waller [ aka quantumstate ]

Wildfire Games Programmer
Contact me: jonathanmarkwaller at gmail dot com


Support Wildfire Games!


#7 BramKaandorp

BramKaandorp

    Tiro

  • Community Newbie
  • 4 posts

Posted 30 March 2012 - 07:10 PM

Thanks, this one is more interesting. Could you give a few more details, I would like to know the game version, what map and how many AI's.


I use "Ides of March", the map is "Giant" IIRC (but the delay also happens on tiny maps when enough units are on the map), and I have 170 units on my side.

I get this from a specific saved game, which I saved for the purpose of getting data, after it got slow. That's why I don't know the specific data of how I set it up.
  • 0

#8 quantumstate

quantumstate

    Primus Pilus

  • WFG Retired
  • 1,150 posts

Posted 31 March 2012 - 08:24 AM

I use "Ides of March", the map is "Giant" IIRC (but the delay also happens on tiny maps when enough units are on the map), and I have 170 units on my side.

I get this from a specific saved game, which I saved for the purpose of getting data, after it got slow. That's why I don't know the specific data of how I set it up.


Thanks, this is helpful. I am working on some changes to the AI which I hope will improve this.
  • 0

Jonathan Waller [ aka quantumstate ]

Wildfire Games Programmer
Contact me: jonathanmarkwaller at gmail dot com


Support Wildfire Games!