Light Style© by Fisana

Jump to content


Photo

multicore support? and water problem.


  • Please log in to reply
2 replies to this topic

#1 billt79

billt79

    Tiro

  • Community Members
  • 5 posts

Posted 22 April 2012 - 07:21 PM

Just noticed before that the game only runs on one core, just thinking it would be significantly quicker if it made use of all of them. Also i'm having problems with water, or at least i think its the water, it causes the game to lag a lot even with no shadows and water reflections. My card is an ATi Mobility Radeon HD4250 on catalyst 12.3 drivers, have tried open source drivers, doesn't make a difference to performance really. water can cause it to drop 20 frames, and on maps with very little water my laptop will happily pull 30+ frames. I would just thinks its just my gfx being slow, but on my cousins desktop (amd sempron, old ati graphics - i think a radeon 9600, 2gb ram) doesn't have a problem, nut on all land maps my laptop is quicker by a few frames when a lot is going on ingame and when the games just started. my setup is an acer aspire 5551, 4gb ram amd athlon p320, ati mobility radeon hd 4250, wd scorpio black and debian sid with kde. desktop effects are disabled while im in game. my cousins computer uses windows xp and is an older version of opengl.
  • 0

#2 feneur

feneur

    Cartographer of imaginary worlds

  • 0 A.D. Project Leader
  • 7,749 posts

Posted 22 April 2012 - 07:34 PM

The game only uses one core for now (partly because of historical reasons: when the development started multicore computers weren't as common as today, if at all, and partly because keeping things on one core makes things like profiling easier), but there are ideas to at least try to put things like AIs in different cores. (For more indepth explanation you'll have to wait for one of the programmers to explain ;) )

In the water games you've played, have you played against AIs? AIs don't yet support water maps, so in addition to the water effects that might be part of what makes things slow.

Have you tried disabling water reflections? (In the in-game settings dialog to quickly toggle it on/off for testing, or by disabling fancywater as per http://trac.wildfire...Manual_Settings )
  • 0

Erik Johansson [ aka feneur ]

Wildfire Games
Contact me: feneur@wildfiregames.com



Support Wildfire Games!


#3 billt79

billt79

    Tiro

  • Community Members
  • 5 posts

Posted 22 April 2012 - 08:15 PM

fancy water and shadows are disabled, i noticed the AI's didnt like water but even at the very start, the game doesn't run very well. This problem occurs with or without AI got profiles of both, profile1 is with AI (qbot). The map is generated from corsica vs sardina and on normal size.

Attached Files


Edited by billt79, 22 April 2012 - 11:34 PM.

  • 0