Light Style© by Fisana

Jump to content


Photo

Alpha X: Problème lors de l'arrêt


  • Please log in to reply
6 replies to this topic

#1 Matx

Matx

    Discens

  • Community Members
  • Pip
  • 11 posts

Posted 27 May 2012 - 04:28 PM

Bonjour à tous,
J'ai un petit soucis avec 0AD lorsque je quitte le jeu: le processus "pyrogenesis.exe *32" reste actif... (Cf. image)
J'ai essayé d'arrêter ce processus mais rien y fait!

Auriez-vous une solution?



Hi all,
I've a little problem with 0AD when I quit the game: the "pyrogenesis.exe *32" process stay active (Cf. image)
I've tried to stop it but it doesn't work!

Would you have a solution?

Matx.


Sans titre.png
  • 0

#2 historic_bruno

historic_bruno

    Primus Pilus

  • WFG Programming Team
  • 2,462 posts

Posted 27 May 2012 - 10:37 PM

Which version of Windows?

Did the game have an error or crash? If not, it will be difficult to troubleshoot without more information. You could try DebugView, a free tool from Microsoft that can display the debug output of the game. It might tell us where the game is failing.
  • 0
Ben Brian [ aka historic_bruno ]

Wildfire Games Programmer
Contact me: ben [at] wildfiregames [dot] com

#3 Matx

Matx

    Discens

  • Community Members
  • Pip
  • 11 posts

Posted 28 May 2012 - 02:56 PM

Which version of Windows?

Did the game have an error or crash? If not, it will be difficult to troubleshoot without more information. You could try DebugView, a free tool from Microsoft that can display the debug output of the game. It might tell us where the game is failing.

I'm under W7 64bits.
The game exit normally, no error message...
I will try your tool!
Thanks a lot!
Matx

[EDIT]This is the screenshot of debug view (because I can't upload the .log file)
I've just launched and left the game
Debug view.png
[/PIAF]

Edited by Matx, 28 May 2012 - 03:09 PM.

  • 0

#4 historic_bruno

historic_bruno

    Primus Pilus

  • WFG Programming Team
  • 2,462 posts

Posted 28 May 2012 - 10:54 PM

Thanks! You could save the .log as .txt to upload or use a service like Pastebin :)

But your screenshot is very useful. Does the game stay frozen in that state permanently? By permanently I mean several minutes later. The next step after "shutdown SDL" is "shutdown UserReporter". Do you have user feedback enabled in the main menu?
  • 0
Ben Brian [ aka historic_bruno ]

Wildfire Games Programmer
Contact me: ben [at] wildfiregames [dot] com

#5 Matx

Matx

    Discens

  • Community Members
  • Pip
  • 11 posts

Posted 29 May 2012 - 09:25 AM

No when I leave the game, it exit normally, none freeze, lag. nothing. :-/
yes I have the feedback enable, but I never sent a message.

PS: I've forgot to say when I leave the game, on my desktop, the music of the main menue continue

thanks a lot for your help!
Matx
  • 0

#6 historic_bruno

historic_bruno

    Primus Pilus

  • WFG Programming Team
  • 2,462 posts

Posted 29 May 2012 - 11:54 PM

If it never closes, that sounds like it's frozen :)

If feedback is enabled, that means the user report system is active and there will often be a 5-10 second delay when shutting it down, if it's in the middle of sending a report. It sounds like in your case there may be something else going wrong. Try disabling user feedback and see if there's any improvement.

What would be really helpful if you're up for the challenge: try our debugging on Windows guide to get the call stack of the game when you notice this problem (WinDbg lets you break into the process and view what the code is doing). That's somewhat advanced, but otherwise it will be hard for us to solve this. I'm also on Windows 7 64-bit and can't reproduce it.
  • 0
Ben Brian [ aka historic_bruno ]

Wildfire Games Programmer
Contact me: ben [at] wildfiregames [dot] com

#7 Matx

Matx

    Discens

  • Community Members
  • Pip
  • 11 posts

Posted 30 May 2012 - 03:35 PM

I've nothing understood, after the install of the debbuging tool, i had to restart my computer. And now the game leave normally.... :-/
(I've kept the feedback enable)

well, I copy paste the output from Windbg, but it's possible there is nothing usefull inside.

If the problem re-appear, I will post the output.

Thanks.

Matx

Attached Files


  • 0